package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((m)|(k)|(Btu(\(th\))?)|(ft)|(m)|(?:\.))+`)
var str = `mBtu(th).ft
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}