$re = '/((m)|(k)|(Btu(\(th\))?)|(ft)|(m)|(?:\.))+/m';
$str = 'mBtu(th).ft
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);