import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(post|merge|delete) (\\/WcfDataService1\\.svc\\/)(.*) HTTP\\/1.1$[\\s\\S]*?(^\\{.+\\}$)";
final String string = "--batchitems\n"
+ "Content-Type: application/http\n"
+ "Content-Transfer-Encoding: binary\n\n"
+ "POST /WcfDataService1.svc/Orders(123) HTTP/1.1\n"
+ " \n"
+ "{\"OrderID\":\"x58\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}