const regex = /^(post|merge|delete) (\/WcfDataService1\.svc\/)(.*) HTTP\/1.1$[\s\S]*?(^{.+\}$)/im;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(post|merge|delete) (\\\/WcfDataService1\\.svc\\\/)(.*) HTTP\\\/1.1$[\\s\\S]*?(^{.+\\}$)', 'im')
const str = `--batchitems
Content-Type: application/http
Content-Transfer-Encoding: binary
POST /WcfDataService1.svc/Orders(123) HTTP/1.1
{"OrderID":"x58"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}