import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http[s]?:\\/\\/)?(www.)?(11st|auction|bj\\.afreecatv|blog\\.naver|blog\\.daum|cafe\\.daum|cafe\\.naver|smartstore\\.naver|storefarm\\.naver|partner\\.booking.naver\\.com|partner\\.booking\\=.naver|shop\\.naver\\.com|gmarket|go\\.kr).*";
final String string = "http://11st.co.kr\n"
+ "http://www.11st.co.kr\n"
+ "http://auction.co.kr\n"
+ "http://blog.naver.com/wef\n"
+ "http://blog.daum.net/wef\n"
+ "http://bj.afreecatv.com/wef\n"
+ "http://cafe.daum.net\n"
+ "http://cafe.naver.com/\n"
+ "http://smartstore.naver.com\n"
+ "http://smartstore.naver.com/wef\n"
+ "storefarm.naver.com\n"
+ "http://partner.booking.naver.com/bizes\n"
+ "http://shop.naver.com/starkrobotics\n"
+ "http://sell.storefarm.naver.com\n"
+ "https://www.rndia.or.kr/\n"
+ "http://m.hakjum.com/\n"
+ "itskorea.kr\n"
+ "minishop.gmarket.co.kr\n"
+ "hrd.keia.kr\n"
+ "www.dsf.go.kr";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}