using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\s*\/\/).*(?=\"").*$";
string input = @"""This shall be moved out of here.""
/// <summary>This method has some ""quoted text""</summary>
// This is ""just a comment""
""This shall be moved out of here."" hai
// This is ""just a comment""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}