$re = '/^(?!\s*\/\/).*(?=\").*$/m';
$str = '"This shall be moved out of here."
/// <summary>This method has some "quoted text"</summary>
// This is "just a comment"
"This shall be moved out of here." hai
// This is "just a comment"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);