package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+(?:-\w+)*`)
var str = `( score + total-score - total-min_score) / papoy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}