$re = '/\w+(?:-\w+)*/m';
$str = '( score + total-score - total-min_score) / papoy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);