package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"([^"]+)"|\w+(?:-\w+)*`)
var str = `Ayala NOT ("Ayala Station" OR "Ayala Branch" OR "Joey Ayala")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}