$re = '/"([^"]+)"|\w+(?:-\w+)*/m';
$str = 'Ayala NOT ("Ayala Station" OR "Ayala Branch" OR "Joey Ayala")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);