package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\B_([a-zA-Z])`)
var str = `$is_data
_construct
test_construct
$test_construct
case 'test_construct':
case $test_construct:
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}