$re = '@\B_([a-zA-Z])@m';
$str = '$is_data
_construct
test_construct
$test_construct
case \'test_construct\':
case $test_construct:
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);