# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bhttps?:\/\/(?!(\w+\.)*(?:CorrectDomain1\.co\.uk|CorrectDomain2\.com|CorrectDomain3\.org)\b[\/\"\s])[^\/\"\s]+"
test_str = ("<a href=\"http://www.WrongDomainA.co.uk\">Link</a>\n"
"<a href=\"http://www.WrongDomainA.co.uk/\">Link</a>\n"
"<a href=\"https://www.WrongDomainA.co.uk/\">Link</a>\n"
"http://www.WrongDomainA.co.uk\n"
"http://www.WrongDomainA.co.uk/\n"
"https://www.WrongDomainA.co.uk\n"
"http://www.CorrectDomain1.co.uk.WrongDomainA.co.uk/\n"
"http://www..WrongDomainA.co.uk/CorrectDomain1.co.uk\n"
"<a href=\"http://www.WrongDomainA.co.uk\">Link</a>\n\n"
"<a href=\"http://www.CorrectDomain1.co.uk\">Link</a>\n"
"<a href=\"http://www.CorrectDomain1.co.uk/\">Link</a>\n"
"http://www.CorrectDomain1.co.uk\n"
"http://www.CorrectDomain1.co.uk/\n\n"
"<a href=\"http://www.CorrectDomain2.com\">Link</a>\n"
"<a href=\"http://www.CorrectDomain2.com/\">Link</a>\n"
"http://www.CorrectDomain2.com\n"
"http://www.CorrectDomain2.com/\n\n"
"<a href=\"https://CorrectDomain2.com/index.php?id=10\">Link</a>\n"
"https://CorrectDomain2.com/index.php?id=10\n\n"
"<a href=\"https://www.CorrectDomain3.org/link\">Link</a>\n"
"https://www.CorrectDomain3.org/link/\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.