re = /\bhttps?:\/\/(?!(\w+\.)*(?:CorrectDomain1\.co\.uk|CorrectDomain2\.com|CorrectDomain3\.org)\b[\/"\s])[^\/"\s]+/m
str = '<a href="http://www.WrongDomainA.co.uk">Link</a>
<a href="http://www.WrongDomainA.co.uk/">Link</a>
<a href="https://www.WrongDomainA.co.uk/">Link</a>
http://www.WrongDomainA.co.uk
http://www.WrongDomainA.co.uk/
https://www.WrongDomainA.co.uk
http://www.CorrectDomain1.co.uk.WrongDomainA.co.uk/
http://www..WrongDomainA.co.uk/CorrectDomain1.co.uk
<a href="http://www.WrongDomainA.co.uk">Link</a>
<a href="http://www.CorrectDomain1.co.uk">Link</a>
<a href="http://www.CorrectDomain1.co.uk/">Link</a>
http://www.CorrectDomain1.co.uk
http://www.CorrectDomain1.co.uk/
<a href="http://www.CorrectDomain2.com">Link</a>
<a href="http://www.CorrectDomain2.com/">Link</a>
http://www.CorrectDomain2.com
http://www.CorrectDomain2.com/
<a href="https://CorrectDomain2.com/index.php?id=10">Link</a>
https://CorrectDomain2.com/index.php?id=10
<a href="https://www.CorrectDomain3.org/link">Link</a>
https://www.CorrectDomain3.org/link/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end