package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\d]*[.][\d]*)*|[\d]|([\+\-\*\(\)\^\/\ \d])`)
var str = `2.0*2^3*(2+3.024)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}