$re = '/([\d]*[.][\d]*)*|[\d]|([\+\-\*\(\)\^\/\ \d])/';
$str = '2.0*2^3*(2+3.024)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);