using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(M=.+?;X=.+?;.+?\.jpg)(.+?(?=(?1)|$))";
string input = @"M=013;X=rast;645.jpgNULœDüŠˆ.....M=217;X=rast;113.jpgNULÿñÿÿ&åbÿås....M=217;X=rast;1108.jpgNUL]_ÿ×ÉcË/...";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}