re = /(M=.+?;X=.+?;.+?\.jpg)(.+?(?=(?1)|$))/
str = 'M=013;X=rast;645.jpgNULœDüŠˆ.....M=217;X=rast;113.jpgNULÿñÿÿ&åbÿås....M=217;X=rast;1108.jpgNUL]_ÿ×ÉcË/...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end