package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)^\+7\(\d{3}\) \d{3}-\d{2}-\d{2}`)
var str = `+7(771) 846-26-14`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}