$re = '/^\+7\(\d{3}\) \d{3}-\d{2}-\d{2}/s';
$str = '+7(771) 846-26-14';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);