#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!_ol).)*$"
Local $sString = "-401234567.pdf" & @CRLF & _
"-401234567a.pdf" & @CRLF & _
"-401234567_a.pdf" & @CRLF & _
"-401234567a_something.pdf" & @CRLF & _
"-401234567_ol.pdf" & @CRLF & _
"-401234567_ol_something.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")