import re
regex = re.compile(r"^((?!_ol).)*$", flags=re.MULTILINE)
test_str = ("-401234567.pdf\n"
"-401234567a.pdf\n"
"-401234567_a.pdf\n"
"-401234567a_something.pdf\n"
"-401234567_ol.pdf\n"
"-401234567_ol_something.pdf")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")