const regex = /(?=\S*\b(?:ua|dev|qa)\b)(?:https?:\/\/(?:www\.|(?!www))[^\s.]+\.\S{2,}|www\.\S+\.\S{2,})/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\S*\\b(?:ua|dev|qa)\\b)(?:https?:\\\/\\\/(?:www\\.|(?!www))[^\\s.]+\\.\\S{2,}|www\\.\\S+\\.\\S{2,})', 'gi')
const str = `www.demo.com
http://foo.co.uk/
http://regexr.com/foo.html?q=bar
https://mediatemple.net
Sample text for testing:
abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ
http://regexrqa.com/foo.html?q=bar
https://qa.mediatemple.net
0123456789 _+-.,!@#\$%^&*();\\/|<>"'
12345 -98.7 3.141 .6180 9,000 +42
http://regexrua.com/foo.html?q=bar
https://ua.mediatemple.net
555.123.4567 +1-(800)-555-2468
foo@demo.net bar.ba@test.co.uk
http://regexrdev.com/foo.html?q=bar
https://dev.mediatemple.net`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}