import re
regex = re.compile(r"(?=\S*\b(?:ua|dev|qa)\b)(?:https?:\/\/(?:www\.|(?!www))[^\s.]+\.\S{2,}|www\.\S+\.\S{2,})", flags=re.IGNORECASE)
test_str = ("www.demo.com \n"
"http://foo.co.uk/\n"
"http://regexr.com/foo.html?q=bar\n"
"https://mediatemple.net\n"
"Sample text for testing:\n"
"abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ\n"
"http://regexrqa.com/foo.html?q=bar\n"
"https://qa.mediatemple.net\n\n"
"0123456789 _+-.,!@#$%^&*();\\/|<>\"'\n"
"12345 -98.7 3.141 .6180 9,000 +42\n"
"http://regexrua.com/foo.html?q=bar\n"
"https://ua.mediatemple.net\n\n"
"555.123.4567 +1-(800)-555-2468\n"
"foo@demo.net bar.ba@test.co.uk\n"
"http://regexrdev.com/foo.html?q=bar\n"
"https://dev.mediatemple.net")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")