using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\b(?<PROJECT>(15-|16-|17-|30-|GGO)\S*)";
string input = @"Does this detect GGO in this string?";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}