$re = '/(?i)\b(?<PROJECT>(15-|16-|17-|30-|GGO)\S*)/';
$str = 'Does this detect GGO in this string?';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);