re = /([0-9a-fA-F]{2}),([0-9a-fA-F]{2}),([0-9a-fA-F]{2}),([0-9a-fA-F]{2})/m
str = '00,01,02,03
01,01,02,03
0C,0D,0E,0F'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result