$re = '/\Bis\B/m';
$str = 'This island is not an aisle';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);