re = /[^\s:]+:(\[[^]]+]|\S+)/m
str = 'key1:value1 key#2:@value#2 nyet key3:[@value#3, value4] key4:[value5] :bar
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end