// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^\s:]+:(\[[^]]+]|\S+)").unwrap();
let string = "key1:value1 key#2:@value#2 nyet key3:[@value#3, value4] key4:[value5] :bar
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}