#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+.|^)facebook(?!.*(cpc|referral))"
Local $sString = "facebook/cpc/[facebook][cpc][house][sale]" & @CRLF & _
"facebook/cpc/[facebook][cpc][condo][sale]" & @CRLF & _
"facebook/referral/[facebook][marketplace][condo][rent]" & @CRLF & _
"facebook/referral/[facebook][marketplace][house][rent]" & @CRLF & _
"m.facebook.com" & @CRLF & _
"facebook.com" & @CRLF & _
"l.facebook.com" & @CRLF & _
"free.facebook.com" & @CRLF & _
"web.facebook.com" & @CRLF & _
"mobile.facebook.com" & @CRLF & _
"lm.facebook.com" & @CRLF & _
"facebook/social/listing"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")