import Foundation
let pattern = #"(\w+.|^)facebook(?!.*(cpc|referral))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
facebook/cpc/[facebook][cpc][house][sale]
facebook/cpc/[facebook][cpc][condo][sale]
facebook/referral/[facebook][marketplace][condo][rent]
facebook/referral/[facebook][marketplace][house][rent]
m.facebook.com
facebook.com
l.facebook.com
free.facebook.com
web.facebook.com
mobile.facebook.com
lm.facebook.com
facebook/social/listing
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)