#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sx)<zwr:risicoNiveau>([^<]*?)</zwr:risicoNiveau>\s*" & @CRLF & _
"<zwr:numeriekeWaarde>([^<]*?)</zwr:numeriekeWaarde>\s*" & @CRLF & _
"<zwr:eenheid>([^<]*?)</zwr:eenheid>\s*" & @CRLF & _
"<zwr:hoedanigheid>([^<]*?)</zwr:hoedanigheid>\s*" & @CRLF & _
"<zwr:kwaliteitsOordeel>([^<]*?)</zwr:kwaliteitsOordeel>\s*" & @CRLF & _
"<zwr:parameterGrootheid>\s*" & @CRLF & _
" <zwr:grootheid>([^<]*?)</zwr:grootheid>\s*" & @CRLF & _
" (?:<zwr:object>([^<]*?)</zwr:object>\s*)?" & @CRLF & _
"</zwr:parameterGrootheid>"
Local $sString = "<zwr:resultaat>" & @CRLF & _
" <zwr:objectBeginTijd>2012-09-18</zwr:objectBeginTijd>" & @CRLF & _
" <zwr:resultaatHistorie>" & @CRLF & _
" <zwr:datumInvoeren>2012-10-31</zwr:datumInvoeren>" & @CRLF & _
" <zwr:invoerder>" & @CRLF & _
" <zwr:voornaam>Joep</zwr:voornaam>" & @CRLF & _
" <zwr:achternaam>Koning, de</zwr:achternaam>" & @CRLF & _
" <zwr:email>jdekoning@hhdelfland.nl</zwr:email>" & @CRLF & _
" <zwr:telefoon>015-2608166</zwr:telefoon>" & @CRLF & _
" <zwr:organisatie>" & @CRLF & _
" <zwr:bedrijfsnaam>Hoogheemraadschap van Delfland</zwr:bedrijfsnaam>" & @CRLF & _
" <zwr:adres>" & @CRLF & _
" <zwr:huisnummer>32</zwr:huisnummer>" & @CRLF & _
" <zwr:postcode>2611AL</zwr:postcode>" & @CRLF & _
" <zwr:straat>Phoenixstraat</zwr:straat>" & @CRLF & _
" <zwr:woonplaats>DELFT</zwr:woonplaats>" & @CRLF & _
" </zwr:adres>" & @CRLF & _
" <zwr:email>info@hhdelfland.nl</zwr:email>" & @CRLF & _
" <zwr:telefoon>(015) 260 81 08</zwr:telefoon>" & @CRLF & _
" <zwr:website>http://www.hhdelfland.nl/</zwr:website>" & @CRLF & _
" </zwr:organisatie>" & @CRLF & _
" </zwr:invoerder>" & @CRLF & _
" </zwr:resultaatHistorie>" & @CRLF & _
" <zwr:risicoNiveau>false</zwr:risicoNiveau>" & @CRLF & _
" <zwr:numeriekeWaarde>0.02</zwr:numeriekeWaarde>" & @CRLF & _
" <zwr:eenheid>kubieke millimeter per liter</zwr:eenheid>" & @CRLF & _
" <zwr:hoedanigheid>niet van toepassing</zwr:hoedanigheid>" & @CRLF & _
" <zwr:kwaliteitsOordeel>Normale waarde</zwr:kwaliteitsOordeel>" & @CRLF & _
" <zwr:parameterGrootheid>" & @CRLF & _
" <zwr:grootheid>Biovolume per volume eenheid</zwr:grootheid>" & @CRLF & _
" " & @CRLF & _
" </zwr:parameterGrootheid>" & @CRLF & _
" <zwr:analyseProces>" & @CRLF & _
" <zwr:analyserendeInstantie>AQUON</zwr:analyserendeInstantie>" & @CRLF & _
" </zwr:analyseProces>" & @CRLF & _
"</zwr:resultaat>" & @CRLF & _
"" & @CRLF & _
"<zwr:resultaat>" & @CRLF & _
" <zwr:objectBeginTijd>2012-09-18</zwr:objectBeginTijd>" & @CRLF & _
" <zwr:resultaatHistorie>" & @CRLF & _
" <zwr:datumInvoeren>2012-10-31</zwr:datumInvoeren>" & @CRLF & _
" <zwr:invoerder>" & @CRLF & _
" <zwr:voornaam>Joep</zwr:voornaam>" & @CRLF & _
" <zwr:achternaam>Koning, de</zwr:achternaam>" & @CRLF & _
" <zwr:email>jdekoning@hhdelfland.nl</zwr:email>" & @CRLF & _
" <zwr:telefoon>015-2608166</zwr:telefoon>" & @CRLF & _
" <zwr:organisatie>" & @CRLF & _
" <zwr:bedrijfsnaam>Hoogheemraadschap van Delfland</zwr:bedrijfsnaam>" & @CRLF & _
" <zwr:adres>" & @CRLF & _
" <zwr:huisnummer>32</zwr:huisnummer>" & @CRLF & _
" <zwr:postcode>2611AL</zwr:postcode>" & @CRLF & _
" <zwr:straat>Phoenixstraat</zwr:straat>" & @CRLF & _
" <zwr:woonplaats>DELFT</zwr:woonplaats>" & @CRLF & _
" </zwr:adres>" & @CRLF & _
" <zwr:email>info@hhdelfland.nl</zwr:email>" & @CRLF & _
" <zwr:telefoon>(015) 260 81 08</zwr:telefoon>" & @CRLF & _
" <zwr:website>http://www.hhdelfland.nl/</zwr:website>" & @CRLF & _
" </zwr:organisatie>" & @CRLF & _
" </zwr:invoerder>" & @CRLF & _
" </zwr:resultaatHistorie>" & @CRLF & _
" <zwr:risicoNiveau>false</zwr:risicoNiveau>" & @CRLF & _
" <zwr:numeriekeWaarde>0.02</zwr:numeriekeWaarde>" & @CRLF & _
" <zwr:eenheid>kubieke millimeter per liter</zwr:eenheid>" & @CRLF & _
" <zwr:hoedanigheid>niet van toepassing</zwr:hoedanigheid>" & @CRLF & _
" <zwr:kwaliteitsOordeel>Normale waarde</zwr:kwaliteitsOordeel>" & @CRLF & _
" <zwr:parameterGrootheid>" & @CRLF & _
" <zwr:grootheid>Biovolume per volume eenheid</zwr:grootheid>" & @CRLF & _
" <zwr:object>Microcystis</zwr:object>" & @CRLF & _
" </zwr:parameterGrootheid>" & @CRLF & _
" <zwr:analyseProces>" & @CRLF & _
" <zwr:analyserendeInstantie>AQUON</zwr:analyserendeInstantie>" & @CRLF & _
" </zwr:analyseProces>" & @CRLF & _
"</zwr:resultaat>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")