import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<zwr:risicoNiveau>([^<]*?)</zwr:risicoNiveau>\\s*\n"
+ "<zwr:numeriekeWaarde>([^<]*?)</zwr:numeriekeWaarde>\\s*\n"
+ "<zwr:eenheid>([^<]*?)</zwr:eenheid>\\s*\n"
+ "<zwr:hoedanigheid>([^<]*?)</zwr:hoedanigheid>\\s*\n"
+ "<zwr:kwaliteitsOordeel>([^<]*?)</zwr:kwaliteitsOordeel>\\s*\n"
+ "<zwr:parameterGrootheid>\\s*\n"
+ " <zwr:grootheid>([^<]*?)</zwr:grootheid>\\s*\n"
+ " (?:<zwr:object>([^<]*?)</zwr:object>\\s*)?\n"
+ "</zwr:parameterGrootheid>";
final String string = "<zwr:resultaat>\n"
+ " <zwr:objectBeginTijd>2012-09-18</zwr:objectBeginTijd>\n"
+ " <zwr:resultaatHistorie>\n"
+ " <zwr:datumInvoeren>2012-10-31</zwr:datumInvoeren>\n"
+ " <zwr:invoerder>\n"
+ " <zwr:voornaam>Joep</zwr:voornaam>\n"
+ " <zwr:achternaam>Koning, de</zwr:achternaam>\n"
+ " <zwr:email>jdekoning@hhdelfland.nl</zwr:email>\n"
+ " <zwr:telefoon>015-2608166</zwr:telefoon>\n"
+ " <zwr:organisatie>\n"
+ " <zwr:bedrijfsnaam>Hoogheemraadschap van Delfland</zwr:bedrijfsnaam>\n"
+ " <zwr:adres>\n"
+ " <zwr:huisnummer>32</zwr:huisnummer>\n"
+ " <zwr:postcode>2611AL</zwr:postcode>\n"
+ " <zwr:straat>Phoenixstraat</zwr:straat>\n"
+ " <zwr:woonplaats>DELFT</zwr:woonplaats>\n"
+ " </zwr:adres>\n"
+ " <zwr:email>info@hhdelfland.nl</zwr:email>\n"
+ " <zwr:telefoon>(015) 260 81 08</zwr:telefoon>\n"
+ " <zwr:website>http://www.hhdelfland.nl/</zwr:website>\n"
+ " </zwr:organisatie>\n"
+ " </zwr:invoerder>\n"
+ " </zwr:resultaatHistorie>\n"
+ " <zwr:risicoNiveau>false</zwr:risicoNiveau>\n"
+ " <zwr:numeriekeWaarde>0.02</zwr:numeriekeWaarde>\n"
+ " <zwr:eenheid>kubieke millimeter per liter</zwr:eenheid>\n"
+ " <zwr:hoedanigheid>niet van toepassing</zwr:hoedanigheid>\n"
+ " <zwr:kwaliteitsOordeel>Normale waarde</zwr:kwaliteitsOordeel>\n"
+ " <zwr:parameterGrootheid>\n"
+ " <zwr:grootheid>Biovolume per volume eenheid</zwr:grootheid>\n"
+ " \n"
+ " </zwr:parameterGrootheid>\n"
+ " <zwr:analyseProces>\n"
+ " <zwr:analyserendeInstantie>AQUON</zwr:analyserendeInstantie>\n"
+ " </zwr:analyseProces>\n"
+ "</zwr:resultaat>\n\n"
+ "<zwr:resultaat>\n"
+ " <zwr:objectBeginTijd>2012-09-18</zwr:objectBeginTijd>\n"
+ " <zwr:resultaatHistorie>\n"
+ " <zwr:datumInvoeren>2012-10-31</zwr:datumInvoeren>\n"
+ " <zwr:invoerder>\n"
+ " <zwr:voornaam>Joep</zwr:voornaam>\n"
+ " <zwr:achternaam>Koning, de</zwr:achternaam>\n"
+ " <zwr:email>jdekoning@hhdelfland.nl</zwr:email>\n"
+ " <zwr:telefoon>015-2608166</zwr:telefoon>\n"
+ " <zwr:organisatie>\n"
+ " <zwr:bedrijfsnaam>Hoogheemraadschap van Delfland</zwr:bedrijfsnaam>\n"
+ " <zwr:adres>\n"
+ " <zwr:huisnummer>32</zwr:huisnummer>\n"
+ " <zwr:postcode>2611AL</zwr:postcode>\n"
+ " <zwr:straat>Phoenixstraat</zwr:straat>\n"
+ " <zwr:woonplaats>DELFT</zwr:woonplaats>\n"
+ " </zwr:adres>\n"
+ " <zwr:email>info@hhdelfland.nl</zwr:email>\n"
+ " <zwr:telefoon>(015) 260 81 08</zwr:telefoon>\n"
+ " <zwr:website>http://www.hhdelfland.nl/</zwr:website>\n"
+ " </zwr:organisatie>\n"
+ " </zwr:invoerder>\n"
+ " </zwr:resultaatHistorie>\n"
+ " <zwr:risicoNiveau>false</zwr:risicoNiveau>\n"
+ " <zwr:numeriekeWaarde>0.02</zwr:numeriekeWaarde>\n"
+ " <zwr:eenheid>kubieke millimeter per liter</zwr:eenheid>\n"
+ " <zwr:hoedanigheid>niet van toepassing</zwr:hoedanigheid>\n"
+ " <zwr:kwaliteitsOordeel>Normale waarde</zwr:kwaliteitsOordeel>\n"
+ " <zwr:parameterGrootheid>\n"
+ " <zwr:grootheid>Biovolume per volume eenheid</zwr:grootheid>\n"
+ " <zwr:object>Microcystis</zwr:object>\n"
+ " </zwr:parameterGrootheid>\n"
+ " <zwr:analyseProces>\n"
+ " <zwr:analyserendeInstantie>AQUON</zwr:analyserendeInstantie>\n"
+ " </zwr:analyseProces>\n"
+ "</zwr:resultaat>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}