package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(-?\d\.\d+)`)
var str = `-1 1:-0.294118 2:0.487437 3:0.180328 4:-0.292929 5:-1 6:0.00149028 7:-0.53117 8:-0.0333333 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}