re = /(-?\d\.\d+)/
str = '-1 1:-0.294118 2:0.487437 3:0.180328 4:-0.292929 5:-1 6:0.00149028 7:-0.53117 8:-0.0333333 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end