package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#\{(.+?)\}`)
var str = `#{apgarscore} >= 0 && #{apgarscore} < 4 && #{apgarcomment} == ''`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}