re = /#\{(.+?)\}/
str = '#{apgarscore} >= 0 && #{apgarscore} < 4 && #{apgarcomment} == \'\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end