#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?:^|(?:000\.[^ ]+))((?:(?!000\.[^ ]+)[\S\s])*)"
Local $sString = "A lot of text before my pattern." & @CRLF & _
"" & @CRLF & _
"Perhaps several lines..." & @CRLF & _
"" & @CRLF & _
"...then 000.SomeLongWordHere!123 Then maybe 000.1a again and some more text to end."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")