$re = '/(?:^|(?:000\.[^ ]+))((?:(?!000\.[^ ]+)[\S\s])*)/im';
$str = 'A lot of text before my pattern.
Perhaps several lines...
...then 000.SomeLongWordHere!123 Then maybe 000.1a again and some more text to end.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);