use strict;
my $str = '北23条東12丁目5-30-405';
my $regex = qr/(丁目)(?=\d)/mp;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";