$re = '/(丁目)(?=\d)/m';
$str = '北23条東12丁目5-30-405';
$subst = "$1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;