#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<([^>]*)>(?:(?!<\/\1>).)*<\1>"
Local $sString = "This is some <b>correct</b> formatting" & @CRLF & _
"This is some <b>incorrect<b> formatting" & @CRLF & _
"This is some <i>incorrect<i> formatting"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")