re = /<([^>]*)>(?:(?!<\/\1>).)*<\1>/
str = 'This is some <b>correct</b> formatting
This is some <b>incorrect<b> formatting
This is some <i>incorrect<i> formatting'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end