using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([abc])(?!\1)([abc])(?!\2|\1)[abc]";
string input = @"adbbcacssesfecabefgswaswabdcbaes";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}