re = /([abc])(?!\1)([abc])(?!\2|\1)[abc]/
str = 'adbbcacssesfecabefgswaswabdcbaes'
# Print the match result
str.match(re) do |match|
puts match.to_s
end