import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<h([1-3]{1})[^>]*?(?! id)(?:id=\\\"([^\\\"]*)\\\"[^>]*)?>)(.*)<\\/h\\2>|<!--nextpage-->";
final String string = "<h1>Test</h1>\n"
+ "<h1 id=\"test\">Test</h1>\n"
+ "<h2 test=\"testattr\" id=\"id\">Test</h2>\n"
+ "<h3 id=\"id\" test=\"test\">Test</h3>\n"
+ "<h3 test=\"test\" id=\"test\" test=\"test\">TEST</h3>\n"
+ "<h4></h4>\n"
+ "test\n"
+ "sdlfkdslf\n"
+ "<table>\n"
+ "h1\n"
+ "<!--nextpage-->";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}