import Foundation
let pattern = #"(<h([1-3]{1})[^>]*?(?! id)(?:id=\"([^\"]*)\"[^>]*)?>)(.*)<\/h\2>|<!--nextpage-->"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<h1>Test</h1>
<h1 id="test">Test</h1>
<h2 test="testattr" id="id">Test</h2>
<h3 id="id" test="test">Test</h3>
<h3 test="test" id="test" test="test">TEST</h3>
<h4></h4>
test
sdlfkdslf
<table>
h1
<!--nextpage-->
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)