#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^SA21 abcdef$)(?!\1)"
Local $sString = "BK udsia" & @CRLF & _
"SA21 abcdef" & @CRLF & _
"BKxyz" & @CRLF & _
"SA21 abcdef"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")